What’s Vulnerable › Vulnerabilities

CVE-2012-2137

Description

Buffer overflow in virt/kvm/irq_comm.c in the KVM subsystem in the Linux kernel before 3.2.24 allows local users to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to Message Signaled Interrupts (MSI), irq routing entries, and an incorrect check by the setup_routing_entry function before invoking the kvm_set_irq function.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.0.72, 3.2.24, 3.4.81. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-2137 or the next vulnerability affects your stack