What’s Vulnerable › Vulnerabilities

CVE-2012-2143

Description

The crypt_des (aka DES-based crypt) function in FreeBSD before 9.0-RELEASE-p2, as used in PHP, PostgreSQL, and other products, does not process the complete cleartext password if this password contains a 0x80 character, which makes it easier for context-dependent attackers to obtain access via an authentication attempt with an initial substring of the intended password, as demonstrated by a Unicode password.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.3.14, 5.4.4; PostgreSQL 8.3.19, 8.4.12, 9.0.8, 9.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-2143 or the next vulnerability affects your stack