What’s Vulnerable › Vulnerabilities

CVE-2012-2237

Description

Multiple cross-site scripting (XSS) vulnerabilities in Mahara 1.4.x before 1.4.3 and 1.5.x before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript innerHTML as used when generating login forms, (2) links or (3) resources URLs, and (4) the Display name in a user profile.

Affected products

How to fix

Upgrade to a fixed version: mahara 1.4.3, 1.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-2237 or the next vulnerability affects your stack