What’s Vulnerable › Vulnerabilities
CVE-2012-2239
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-11-24 · updated 2026-06-16
- Weakness: CWE-611
Description
Mahara 1.4.x before 1.4.4 and 1.5.x before 1.5.3 allows remote attackers to read arbitrary files or create TCP connections via an XML external entity (XXE) injection attack, as demonstrated by reading config.php.
Affected products
- Debian Linux: 6.0
- mahara: from 1.4.0 before 1.4.4; from 1.5.0 before 1.5.3 — fixed in 1.4.4, 1.5.3
How to fix
Upgrade to a fixed version: mahara 1.4.4, 1.5.3. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2012/dsa-2591
- https://bugs.launchpad.net/mahara/+bug/1047111
- https://mahara.org/interaction/forum/topic.php?id=4869
- http://www.debian.org/security/2012/dsa-2591
- https://bugs.launchpad.net/mahara/+bug/1047111
- https://mahara.org/interaction/forum/topic.php?id=4869
Get alerted when CVE-2012-2239 or the next vulnerability affects your stack