What’s Vulnerable › Vulnerabilities
CVE-2012-2452
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-11 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in pragmaMx 1.x before 1.12.2 allow remote attackers to inject arbitrary web script or HTML via the (1) name parameter to modules.php or (2) img_url to includes/wysiwyg/spaw/editor/plugins/imgpopup/img_popup.php.
Affected products
- Pragmamx: from 1.0 before 1.12.2 — fixed in 1.12.2
How to fix
Upgrade to a fixed version: Pragmamx 1.12.2. Check the vendor advisory for mitigations.
References
- http://www.pragmamx.org/Forum-topic-33554.html
- http://www.pragmamx.org/News-pragmaMx-1.12-Servicepack2-item-706.html
- https://www.htbridge.com/advisory/HTB23090
- http://www.pragmamx.org/Forum-topic-33554.html
- http://www.pragmamx.org/News-pragmaMx-1.12-Servicepack2-item-706.html
- https://www.htbridge.com/advisory/HTB23090
Get alerted when CVE-2012-2452 or the next vulnerability affects your stack