What’s Vulnerable › Vulnerabilities
CVE-2012-2517
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-11 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in PrestaShop before 1.4.9 allows remote attackers to inject arbitrary web script or HTML via the index of the product[] parameter to ajax.php.
Affected products
- PrestaShop: before 1.4.9.0 — fixed in 1.4.9.0
How to fix
Upgrade to a fixed version: PrestaShop 1.4.9.0. Check the vendor advisory for mitigations.
References
- https://www.htbridge.com/advisory/HTB23091
- https://www.prestashop.com/download/old/changelog_1.4.9.0.txt
- https://www.htbridge.com/advisory/HTB23091
- https://www.prestashop.com/download/old/changelog_1.4.9.0.txt
Get alerted when CVE-2012-2517 or the next vulnerability affects your stack