What’s Vulnerable › Vulnerabilities
CVE-2012-2665
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-08-06 · updated 2026-06-16
- Weakness: CWE-787
Description
Multiple heap-based buffer overflows in the XML manifest encryption tag parsing functionality in OpenOffice.org and LibreOffice before 3.5.5 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Open Document Text (.odt) file with (1) a child tag within an incorrect parent tag, (2) duplicate tags, or (3) a Base64 ChecksumAttribute whose length is not evenly divisible by four.
Affected products
- Apache Software Foundation Apache OpenOffice: before 3.4.1 — fixed in 3.4.1
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04
- Debian Linux: 6.0, 7.0
- The Document Foundation LibreOffice: before 3.5.5 — fixed in 3.5.5
- Red Hat Enterprise Linux: 6.0
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux For Ibm Z Systems: 6.0
- RedHat Enterprise Linux For Power Big Endian: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server From Rhui 6: 6.0
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 3.4.1; The Document Foundation LibreOffice 3.5.5. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2012-1135.html
- http://secunia.com/advisories/50142
- http://secunia.com/advisories/50146
- http://secunia.com/advisories/50692
- http://secunia.com/advisories/60799
- http://security.gentoo.org/glsa/glsa-201209-05.xml
- http://www.debian.org/security/2012/dsa-2520
- http://www.gentoo.org/security/en/glsa/glsa-201408-19.xml
- http://www.libreoffice.org/about-us/security/advisories/cve-2012-2665/
- http://www.pre-cert.de/advisories/PRE-SA-2012-05.txt
- http://www.securityfocus.com/bid/54769
- http://www.securitytracker.com/id?1027331
Get alerted when CVE-2012-2665 or the next vulnerability affects your stack