What’s Vulnerable › Vulnerabilities
CVE-2012-2750
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-08-17 · updated 2026-06-16
Description
Unspecified vulnerability in MySQL 5.5.x before 5.5.23 has unknown impact and attack vectors related to a "Security Fix", aka Bug #59533. NOTE: this might be a duplicate of CVE-2012-1689, but as of 20120816, Oracle has not commented on this possibility.
Affected products
- Debian Linux: 6.0
- MariaDB: from 5.5.0 through 5.5.23
- MySQL Server: from 5.5.0 before 5.5.23 — fixed in 5.5.23
How to fix
Upgrade to a fixed version: MySQL Server 5.5.23. Check the vendor advisory for mitigations.
References
- http://dev.mysql.com/doc/refman/5.5/en/news-5-5-23.html
- http://www.debian.org/security/2013/dsa-2780
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:250
- http://www.securityfocus.com/bid/63125
- http://www.securitytracker.com/id/1029184
- https://bugzilla.redhat.com/show_bug.cgi?id=833742
- http://dev.mysql.com/doc/refman/5.5/en/news-5-5-23.html
- http://www.debian.org/security/2013/dsa-2780
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:250
- http://www.securityfocus.com/bid/63125
- http://www.securitytracker.com/id/1029184
- https://bugzilla.redhat.com/show_bug.cgi?id=833742
Get alerted when CVE-2012-2750 or the next vulnerability affects your stack