What’s Vulnerable › Vulnerabilities
CVE-2012-2751
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-07-22 · updated 2026-06-16
Description
ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.
Affected products
- Debian Linux: 6.0, 7.0
- Opensuse: 11.4, 12.2, 12.3
- Oracle Corporation Oracle HTTP Server: 11.1.1.6.0
- Trustwave Modsecurity: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.6.6. Check the vendor advisory for mitigations.
References
- http://blog.ivanristic.com/2012/06/modsecurity-and-modsecurity-core-rule-set-multipart-bypasses.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00020.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00025.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00031.html
- http://mod-security.svn.sourceforge.net/viewvc/mod-security/m2/branches/2.6.x/CHANGES
- http://mod-security.svn.sourceforge.net/viewvc/mod-security/m2/trunk/CHANGES?r1=1920&r2=1919&pathrev=1920
- http://mod-security.svn.sourceforge.net/viewvc/mod-security/m2/trunk/apache2/msc_multipart.c?r1=1918&r2=1917&pathrev=1918
- http://secunia.com/advisories/49576
- http://secunia.com/advisories/49782
- http://www.debian.org/security/2012/dsa-2506
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:118
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
Get alerted when CVE-2012-2751 or the next vulnerability affects your stack