What’s Vulnerable › Vulnerabilities
CVE-2012-2931
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-09 · updated 2026-06-16
- Weakness: CWE-74
Description
PHP code injection in TinyWebGallery before 1.8.8 allows remote authenticated users with admin privileges to inject arbitrary code into the .htusers.php file.
Affected products
- TinyWebGallery: before 1.8.8 — fixed in 1.8.8
How to fix
Upgrade to a fixed version: TinyWebGallery 1.8.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2012-2931 or the next vulnerability affects your stack