What’s Vulnerable › Vulnerabilities
CVE-2012-2950
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-09 · updated 2026-06-16
- Weakness: CWE-434
Description
Gateway Geomatics MapServer for Windows before 3.0.6 contains a Local File Include Vulnerability which allows remote attackers to execute local PHP code and obtain sensitive information.
Affected products
- Gatewaygeomatics Mapserver: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Gatewaygeomatics Mapserver 3.0.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/53737
- https://exchange.xforce.ibmcloud.com/vulnerabilities/75983
- http://www.securityfocus.com/bid/53737
- https://exchange.xforce.ibmcloud.com/vulnerabilities/75983
Get alerted when CVE-2012-2950 or the next vulnerability affects your stack