What’s Vulnerable › Vulnerabilities
CVE-2012-3163
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-10-17 · updated 2026-06-16
Description
Unspecified vulnerability in the MySQL Server component in Oracle MySQL 5.1.64 and earlier, and 5.5.26 and earlier, allows remote authenticated users to affect confidentiality, integrity, and availability via unknown vectors related to Information Schema.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- Debian Linux: 6.0, 7.0
- F5 BIG-IP APM: from 10.1.0 through 10.2.4; from 11.0.0 through 11.3.0
- BIG-IP: 11.3.0
- F5 Big-Ip Analytics: from 11.0.0 through 11.3.0
- BIG-IP ASM: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Big-Ip Edge Gateway: from 10.1.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Networks BIG-IP, Enterprise Manager: from 2.0.0 through 2.3.0; from 3.0.0 through 3.1.1
- F5 Big-Ip Global Traffic Manager: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Big-Ip Link Controller: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 BIG-IP (LTM): from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Networks, Inc. BIG-IP (PEM): 11.3.0
- F5 Big-Ip Protocol Security Module: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Big-Ip Wan Optimization Manager: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- F5 Big-Ip Webaccelerator: from 10.0.0 through 10.2.4; from 11.0.0 through 11.3.0
- MariaDB: from 5.1 before 5.1.66; from 5.5.0 before 5.5.27 — fixed in 5.1.66, 5.5.27
- MySQL Server: from 5.1.0 through 5.1.64; from 5.5.0 through 5.5.26
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.3
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: MariaDB 5.1.66, 5.5.27. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2012-1462.html
- http://secunia.com/advisories/51177
- http://secunia.com/advisories/51309
- http://secunia.com/advisories/53372
- http://secunia.com/advisories/56509
- http://secunia.com/advisories/56513
- http://security.gentoo.org/glsa/glsa-201308-06.xml
- http://support.f5.com/kb/en-us/solutions/public/14000/900/sol14907.html
- http://www.debian.org/security/2012/dsa-2581
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
- http://www.oracle.com/technetwork/topics/security/cpuoct2012-1515893.html
- http://www.ubuntu.com/usn/USN-1621-1
Get alerted when CVE-2012-3163 or the next vulnerability affects your stack