What’s Vulnerable › Vulnerabilities
CVE-2012-3400
- Severity: high (CVSS 7.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-10-03 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in the udf_load_logicalvol function in fs/udf/super.c in the Linux kernel before 3.4.5 allows remote attackers to cause a denial of service (system crash) or possibly have unspecified other impact via a crafted UDF filesystem.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 12.04
- Linux kernel: before 3.0.37; from 3.1 before 3.2.23; from 3.4 before 3.4.5 — fixed in 3.0.37, 3.2.23, 3.4.5
How to fix
Upgrade to a fixed version: Linux kernel 3.0.37, 3.2.23, 3.4.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=1df2ae31c724e57be9d7ac00d78db8a5dabdd050
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=adee11b2085bee90bd8f4f52123ffb07882d6256
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10691
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00020.html
- http://rhn.redhat.com/errata/RHSA-2013-0594.html
- http://secunia.com/advisories/50506
- http://ubuntu.com/usn/usn-1529-1
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.4.5
- http://www.openwall.com/lists/oss-security/2012/07/10/2
- http://www.ubuntu.com/usn/USN-1555-1
- http://www.ubuntu.com/usn/USN-1556-1
- http://www.ubuntu.com/usn/USN-1557-1
Get alerted when CVE-2012-3400 or the next vulnerability affects your stack