What’s Vulnerable › Vulnerabilities
CVE-2012-3408
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-08-06 · updated 2026-06-16
- Weakness: CWE-287
Description
lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which might allow remote attackers to spoof an agent by acquiring a previously used IP address.
Affected products
- Puppet Enterprise: before 2.5.2 — fixed in 2.5.2
- Puppetlabs Puppet: before 2.7.18 — fixed in 2.7.18
How to fix
Upgrade to a fixed version: Puppet Enterprise 2.5.2; Puppetlabs Puppet 2.7.18. Check the vendor advisory for mitigations.
References
- http://puppetlabs.com/security/cve/cve-2012-3408/
- https://bugzilla.redhat.com/show_bug.cgi?id=839166
- https://github.com/puppetlabs/puppet/commit/ab9150baa1b738467a33b01df1d90e076253fbbd
- http://puppetlabs.com/security/cve/cve-2012-3408/
- https://bugzilla.redhat.com/show_bug.cgi?id=839166
- https://github.com/puppetlabs/puppet/commit/ab9150baa1b738467a33b01df1d90e076253fbbd
Get alerted when CVE-2012-3408 or the next vulnerability affects your stack