What’s Vulnerable › Vulnerabilities
CVE-2012-3412
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-10-03 · updated 2026-06-16
- Weakness: CWE-189
Description
The sfc (aka Solarflare Solarstorm) driver in the Linux kernel before 3.2.30 allows remote attackers to cause a denial of service (DMA descriptor consumption and network-controller outage) via crafted TCP packets that trigger a small MSS value.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04
- Linux kernel: before 3.0.44; from 3.1 before 3.2.30; from 3.3 before 3.4.12; from 3.5 before 3.5.5 — fixed in 3.0.44, 3.2.30, 3.4.12, 3.5.5
How to fix
Upgrade to a fixed version: Linux kernel 3.0.44, 3.2.30, 3.4.12, 3.5.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-10/msg00005.html
- http://rhn.redhat.com/errata/RHSA-2012-1323.html
- http://rhn.redhat.com/errata/RHSA-2012-1324.html
- http://rhn.redhat.com/errata/RHSA-2012-1347.html
- http://rhn.redhat.com/errata/RHSA-2012-1375.html
- http://rhn.redhat.com/errata/RHSA-2012-1401.html
- http://rhn.redhat.com/errata/RHSA-2012-1430.html
- http://secunia.com/advisories/50633
- http://secunia.com/advisories/50732
- http://secunia.com/advisories/50811
- http://secunia.com/advisories/51193
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.30
Get alerted when CVE-2012-3412 or the next vulnerability affects your stack