What’s Vulnerable › Vulnerabilities
CVE-2012-3509
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-09-05 · updated 2026-06-16
- Weakness: CWE-189
Description
Multiple integer overflows in the (1) _objalloc_alloc function in objalloc.c and (2) objalloc_alloc macro in include/objalloc.h in GNU libiberty, as used by binutils 2.22, allow remote attackers to cause a denial of service (crash) via vectors related to the "addition of CHUNK_HEADER_SIZE to the length," which triggers a heap-based buffer overflow.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 14.04, 14.10
- Debian Linux: 7.0
- GNU Binutils: from 2.22 before 2.24 — fixed in 2.24
- GNU Libiberty: all versions
How to fix
Upgrade to a fixed version: GNU Binutils 2.24. Check the vendor advisory for mitigations.
References
- http://gcc.gnu.org/bugzilla/show_bug.cgi?id=54411
- http://gcc.gnu.org/ml/gcc-patches/2012-08/msg01986.html
- http://security-tracker.debian.org/tracker/CVE-2012-3509
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:029
- http://www.openwall.com/lists/oss-security/2012/08/29/3
- http://www.securityfocus.com/bid/55281
- http://www.ubuntu.com/usn/USN-2496-1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/78135
- http://gcc.gnu.org/bugzilla/show_bug.cgi?id=54411
- http://gcc.gnu.org/ml/gcc-patches/2012-08/msg01986.html
- http://security-tracker.debian.org/tracker/CVE-2012-3509
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:029
Get alerted when CVE-2012-3509 or the next vulnerability affects your stack