What’s Vulnerable › Vulnerabilities
CVE-2012-3515
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-11-23 · updated 2026-06-16
- Weakness: CWE-20
Description
Qemu, as used in Xen 4.0, 4.1 and possibly other products, when emulating certain devices with a virtual console backend, allows local OS guest users to gain privileges via a crafted escape VT100 sequence that triggers the overwrite of a "device model's address space."
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04
- Debian Linux: 6.0, 7.0
- Opensuse: 11.4, 12.1, 12.2
- QEMU: before 1.2.0 — fixed in 1.2.0
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.3
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- RedHat Virtualization: 3.0, 5.0, 6.0
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp2
- SUSE Linux Enterprise Server: 10-sp2, 10-sp3, 10-sp4, 11-sp1, 11-sp2
- SUSE Linux Enterprise Software Development Kit: 10-sp4, 11-sp2
- xen: 4.0.0, 4.1.0
How to fix
Upgrade to a fixed version: QEMU 1.2.0. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu-stable-0.15.git%3Ba=log
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2012-09/msg00027.html
Get alerted when CVE-2012-3515 or the next vulnerability affects your stack