What’s Vulnerable › Vulnerabilities

CVE-2012-3967

Description

The WebGL implementation in Mozilla Firefox before 15.0, Firefox ESR 10.x before 10.0.7, Thunderbird before 15.0, Thunderbird ESR 10.x before 10.0.7, and SeaMonkey before 2.12 on Linux, when a large number of sampler uniforms are used, does not properly interact with Mesa drivers, which allows remote attackers to execute arbitrary code or cause a denial of service (stack memory corruption) via a crafted web site.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 10.0.7, 15.0; Mozilla Seamonkey 2.12; Mozilla Thunderbird 15.0; Mozilla Thunderbird ESR 10.0.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-3967 or the next vulnerability affects your stack