What’s Vulnerable › Vulnerabilities
CVE-2012-4185
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-10-10 · updated 2026-06-16
- Weakness: CWE-119
Description
Buffer overflow in the nsCharTraits::length function in Mozilla Firefox before 16.0, Firefox ESR 10.x before 10.0.8, Thunderbird before 16.0, Thunderbird ESR 10.x before 10.0.8, and SeaMonkey before 2.13 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04
- Mozilla Firefox: before 10.0.8; before 16.0 — fixed in 10.0.8, 16.0
- Mozilla Seamonkey: before 2.13 — fixed in 2.13
- Mozilla Thunderbird: before 16.0 — fixed in 16.0
- Mozilla Thunderbird ESR: before 10.0.8 — fixed in 10.0.8
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.3
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp3
- SUSE Linux Enterprise Sdk: 10-sp4
- SUSE Linux Enterprise Server: 10-sp4, 11-sp3
How to fix
Upgrade to a fixed version: Mozilla Firefox 10.0.8, 16.0; Mozilla Seamonkey 2.13; Mozilla Thunderbird 16.0; Mozilla Thunderbird ESR 10.0.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-10/msg00010.html
- http://osvdb.org/86116
- http://rhn.redhat.com/errata/RHSA-2012-1351.html
- http://secunia.com/advisories/50856
- http://secunia.com/advisories/50892
- http://secunia.com/advisories/50904
- http://secunia.com/advisories/50935
- http://secunia.com/advisories/50936
- http://secunia.com/advisories/50984
- http://secunia.com/advisories/55318
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:163
- http://www.mozilla.org/security/announce/2012/mfsa2012-86.html
Get alerted when CVE-2012-4185 or the next vulnerability affects your stack