What’s Vulnerable › Vulnerabilities

CVE-2012-4187

Description

Mozilla Firefox before 16.0, Firefox ESR 10.x before 10.0.8, Thunderbird before 16.0, Thunderbird ESR 10.x before 10.0.8, and SeaMonkey before 2.13 do not properly manage a certain insPos variable, which allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption and assertion failure) via unspecified vectors.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 10.0.8, 16.0; Mozilla Seamonkey 2.13; Mozilla Thunderbird 16.0; Mozilla Thunderbird ESR 10.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-4187 or the next vulnerability affects your stack