What’s Vulnerable › Vulnerabilities
CVE-2012-4388
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-09-07 · updated 2026-06-16
- Weakness: CWE-20
Description
The sapi_header_op function in main/SAPI.c in PHP 5.4.0RC2 through 5.4.0 does not properly determine a pointer during checks for %0D sequences (aka carriage return characters), which allows remote attackers to bypass an HTTP response-splitting protection mechanism via a crafted URL, related to improper interaction between the PHP header function and certain browsers, as demonstrated by Internet Explorer and Google Chrome. NOTE: this vulnerability exists because of an incorrect fix for CVE-2011-1398.
Affected products
- Canonical Ubuntu Linux: 8.04, 10.04, 11.04, 11.10, 12.04
- Debian Linux: 6.0
- PHP: from 5.3.0 before 5.3.11; 5.4.0-rc2 — fixed in 5.3.11
How to fix
Upgrade to a fixed version: PHP 5.3.11. Check the vendor advisory for mitigations.
References
- http://article.gmane.org/gmane.comp.php.devel/70584
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00006.html
- http://openwall.com/lists/oss-security/2012/08/29/5
- http://openwall.com/lists/oss-security/2012/09/02/1
- http://openwall.com/lists/oss-security/2012/09/05/15
- http://openwall.com/lists/oss-security/2012/09/07/3
- http://security-tracker.debian.org/tracker/CVE-2012-4388
- http://svn.php.net/viewvc/php/php-src/branches/PHP_5_4/main/SAPI.c?r1=323986&r2=323985&pathrev=323986
- http://www.securitytracker.com/id?1027463
- http://www.ubuntu.com/usn/USN-1569-1
- https://bugs.php.net/bug.php?id=60227
- http://article.gmane.org/gmane.comp.php.devel/70584
Get alerted when CVE-2012-4388 or the next vulnerability affects your stack