What’s Vulnerable › Vulnerabilities
CVE-2012-4434
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-09 · updated 2026-06-16
- Weakness: CWE-276
Description
fwknop before 2.0.3 allow remote authenticated users to cause a denial of service (server crash) or possibly execute arbitrary code.
Affected products
- fwknop: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: fwknop 2.0.3. Check the vendor advisory for mitigations.
References
- http://www.cipherdyne.org/blog/2012/09/software-release-fwknop-2.0.3.html
- http://www.openwall.com/lists/oss-security/2012/09/19/2
- http://www.openwall.com/lists/oss-security/2012/09/20/4
- http://www.cipherdyne.org/blog/2012/09/software-release-fwknop-2.0.3.html
- http://www.openwall.com/lists/oss-security/2012/09/19/2
- http://www.openwall.com/lists/oss-security/2012/09/20/4
Get alerted when CVE-2012-4434 or the next vulnerability affects your stack