What’s Vulnerable › Vulnerabilities
CVE-2012-4440
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.
Affected products
- Jenkins: before 1.466.2; before 1.482 — fixed in 1.466.2, 1.482
How to fix
Upgrade to a fixed version: Jenkins 1.466.2, 1.482. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2012/09/21/2
- https://security-tracker.debian.org/tracker/CVE-2012-4440
- https://www.cloudbees.com/jenkins-security-advisory-2012-09-17
- http://www.openwall.com/lists/oss-security/2012/09/21/2
- https://security-tracker.debian.org/tracker/CVE-2012-4440
- https://www.cloudbees.com/jenkins-security-advisory-2012-09-17
Get alerted when CVE-2012-4440 or the next vulnerability affects your stack