What’s Vulnerable › Vulnerabilities
CVE-2012-4451
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-03 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Zend Framework 2.0.x before 2.0.1 allow remote attackers to inject arbitrary web script or HTML via unspecified input to (1) Debug, (2) Feed\PubSubHubbub, (3) Log\Formatter\Xml, (4) Tag\Cloud\Decorator, (5) Uri, (6) View\Helper\HeadStyle, (7) View\Helper\Navigation\Sitemap, or (8) View\Helper\Placeholder\Container\AbstractStandalone, related to Escaper.
Affected products
- Fedoraproject Fedora: 16, 17
- Red Hat Enterprise Linux: 6.0
- Zend Technologies Zend Framework: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Zend Technologies Zend Framework 2.0.1. Check the vendor advisory for mitigations.
References
- http://framework.zend.com/security/advisory/ZF2012-03
- http://seclists.org/oss-sec/2012/q3/571
- http://seclists.org/oss-sec/2012/q3/573
- http://www.securityfocus.com/bid/55636
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=688946#10
- https://bugs.gentoo.org/show_bug.cgi?id=436210
- https://bugzilla.redhat.com/show_bug.cgi?id=860738
- https://github.com/zendframework/zf2/commit/27131ca9520bdf1d4c774c71459eba32f2b10733
- http://framework.zend.com/security/advisory/ZF2012-03
- http://seclists.org/oss-sec/2012/q3/571
- http://seclists.org/oss-sec/2012/q3/573
- http://www.securityfocus.com/bid/55636
Get alerted when CVE-2012-4451 or the next vulnerability affects your stack