What’s Vulnerable › Vulnerabilities
CVE-2012-4528
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-12-28 · updated 2026-06-16
Description
The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.
Affected products
- Fedoraproject Fedora: 18
- Opensuse: 11.4, 12.2, 12.3
- Trustwave Modsecurity: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.7.0. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2012-November/093011.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00020.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00025.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00031.html
- http://mod-security.svn.sourceforge.net/viewvc/mod-security/m2/branches/2.7.x/CHANGES
- http://mod-security.svn.sourceforge.net/viewvc/mod-security/m2/trunk/apache2/msc_multipart.c?sortby=date&r1=2081&r2=2080&pathrev=2081
- http://mod-security.svn.sourceforge.net/viewvc/mod-security?view=revision&sortby=date&revision=2081
- http://seclists.org/fulldisclosure/2012/Oct/113
- http://www.openwall.com/lists/oss-security/2012/10/18/14
- https://www.sec-consult.com/fxdata/seccons/prod/temedia/advisories_txt/20121017-0_mod_security_ruleset_bypass.txt
- http://lists.fedoraproject.org/pipermail/package-announce/2012-November/093011.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00020.html
Get alerted when CVE-2012-4528 or the next vulnerability affects your stack