What’s Vulnerable › Vulnerabilities

CVE-2012-5285

Description

Buffer overflow in Adobe Flash Player before 10.3.183.29 and 11.x before 11.4.402.287 on Windows and Mac OS X, before 10.3.183.29 and 11.x before 11.2.202.243 on Linux, before 11.1.111.19 on Android 2.x and 3.x, and before 11.1.115.20 on Android 4.x; Adobe AIR before 3.4.0.2710; and Adobe AIR SDK before 3.4.0.2710 allows attackers to execute arbitrary code via unspecified vectors, a different vulnerability than other Flash Player buffer overflow CVEs listed in APSB12-22.

Affected products

How to fix

Upgrade to a fixed version: Adobe Air 3.4.0.2710; Adobe Air Sdk 3.4.0.2710; Adobe Flash Player 24.0.0.186 and earlier. 10.3.183.29, 11.1.111.19, 11.1.115.20, 11.2.202.243. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-5285 or the next vulnerability affects your stack