What’s Vulnerable › Vulnerabilities
CVE-2012-5576
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-12-18 · updated 2026-06-16
- Weakness: CWE-787
Description
Multiple stack-based buffer overflows in file-xwd.c in the X Window Dump (XWD) plug-in in GIMP 2.8.2 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large (1) red, (2) green, or (3) blue color mask in an XWD file.
Affected products
- GIMP: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: GIMP 2.8.4. Check the vendor advisory for mitigations.
References
- http://git.gnome.org/browse/gimp/commit/?id=2873262fccba12af144ed96ed91be144d92ff2e1
- http://lists.opensuse.org/opensuse-updates/2012-12/msg00017.html
- http://lists.opensuse.org/opensuse-updates/2013-01/msg00014.html
- http://secunia.com/advisories/50296
- http://secunia.com/advisories/51479
- http://secunia.com/advisories/51528
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:082
- http://www.openwall.com/lists/oss-security/2012/11/27/1
- http://www.securityfocus.com/bid/56647
- http://www.ubuntu.com/usn/USN-1659-1
- https://bugzilla.gnome.org/show_bug.cgi?id=687392
- http://git.gnome.org/browse/gimp/commit/?id=2873262fccba12af144ed96ed91be144d92ff2e1
Get alerted when CVE-2012-5576 or the next vulnerability affects your stack