What’s Vulnerable › Vulnerabilities
CVE-2012-5612
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-12-03 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in Oracle MySQL 5.5.19 and other versions through 5.5.28, and MariaDB 5.5.28a and possibly other versions, allows remote authenticated users to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code, as demonstrated using certain variations of the (1) USE, (2) SHOW TABLES, (3) DESCRIBE, (4) SHOW FIELDS FROM, (5) SHOW COLUMNS FROM, (6) SHOW INDEX FROM, (7) CREATE TABLE, (8) DROP TABLE, (9) ALTER TABLE, (10) DELETE FROM, (11) UPDATE, and (12) SET PASSWORD commands.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- MariaDB: from 5.1.0 before 5.1.67; from 5.2.0 before 5.2.14; from 5.3.0 before 5.3.12; from 5.5.0 before 5.5.29; 10.0.0 — fixed in 5.1.67, 5.2.14, 5.3.12, 5.5.29
- MySQL Server: from 5.5.0 through 5.5.28
- SUSE Linux Enterprise Server 15 SP1: 11-sp2
- SUSE Linux Enterprise Server: 11-sp2
- SUSE Linux Enterprise Software Development Kit: 11-sp2
How to fix
Upgrade to a fixed version: MariaDB 5.1.67, 5.2.14, 5.3.12, 5.5.29. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-02/msg00000.html
- http://seclists.org/fulldisclosure/2012/Dec/5
- http://secunia.com/advisories/53372
- http://security.gentoo.org/glsa/glsa-201308-06.xml
- http://www.exploit-db.com/exploits/23076
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:102
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
- http://www.openwall.com/lists/oss-security/2012/12/02/3
- http://www.openwall.com/lists/oss-security/2012/12/02/4
- http://www.oracle.com/technetwork/topics/security/cpujan2013-1515902.html
- http://www.ubuntu.com/usn/USN-1703-1
- https://mariadb.atlassian.net/browse/MDEV-3908
Get alerted when CVE-2012-5612 or the next vulnerability affects your stack