What’s Vulnerable › Vulnerabilities
CVE-2012-5614
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-12-03 · updated 2026-06-16
Description
Oracle MySQL 5.1.67 and earlier and 5.5.29 and earlier, and MariaDB 5.5.28a and possibly other versions, allows remote authenticated users to cause a denial of service (mysqld crash) via a SELECT command with an UpdateXML command containing XML with a large number of unique, nested elements.
Affected products
- MariaDB: from 5.5.0 before 5.5.30; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 5.5.30
- MySQL Server: from 5.1.0 through 5.1.67; from 5.5.0 through 5.5.29
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.4
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 6.4
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.2, 5.5.30. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2013-0772.html
- http://seclists.org/fulldisclosure/2012/Dec/7
- http://secunia.com/advisories/53372
- http://security.gentoo.org/glsa/glsa-201308-06.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
- http://www.openwall.com/lists/oss-security/2012/12/02/3
- http://www.openwall.com/lists/oss-security/2012/12/02/4
- http://www.oracle.com/technetwork/topics/security/cpuapr2013-1899555.html
- http://www.securitytracker.com/id?1027829
- https://bugzilla.redhat.com/show_bug.cgi?id=882607
- https://mariadb.atlassian.net/browse/MDEV-3910
- http://rhn.redhat.com/errata/RHSA-2013-0772.html
Get alerted when CVE-2012-5614 or the next vulnerability affects your stack