What’s Vulnerable › Vulnerabilities
CVE-2012-5618
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-04 · updated 2026-06-16
- Weakness: CWE-640
Description
Ushahidi before 2.6.1 has insufficient entropy for forgot-password tokens.
Affected products
- Ushahidi: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: Ushahidi 2.6.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2012/12/04/1
- https://github.com/ushahidi/Ushahidi_Web/commit/e8c7ecd42818c331db8945d20f8b1865bc6d157e
- http://www.openwall.com/lists/oss-security/2012/12/04/1
- https://github.com/ushahidi/Ushahidi_Web/commit/e8c7ecd42818c331db8945d20f8b1865bc6d157e
Get alerted when CVE-2012-5618 or the next vulnerability affects your stack