What’s Vulnerable › Vulnerabilities

CVE-2012-5627

Description

Oracle MySQL and MariaDB 5.5.x before 5.5.29, 5.3.x before 5.3.12, and 5.2.x before 5.2.14 does not modify the salt during multiple executions of the change_user command within the same connection which makes it easier for remote authenticated users to conduct brute force password guessing attacks.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 5.2.14, 5.3.12, 5.5.29; MySQL Server 5.5.29. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-5627 or the next vulnerability affects your stack