What’s Vulnerable › Vulnerabilities
CVE-2012-5678
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-12-12 · updated 2026-06-16
- Weakness: CWE-119
Description
Adobe Flash Player before 10.3.183.48 and 11.x before 11.5.502.135 on Windows, before 10.3.183.48 and 11.x before 11.5.502.136 on Mac OS X, before 10.3.183.48 and 11.x before 11.2.202.258 on Linux, before 11.1.111.29 on Android 2.x and 3.x, and before 11.1.115.34 on Android 4.x; Adobe AIR before 3.5.0.880 on Windows and before 3.5.0.890 on Mac OS X; and Adobe AIR SDK before 3.5.0.880 on Windows and before 3.5.0.890 on Mac OS X allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors.
Affected products
- Adobe Air: before 3.5.0.880; before 3.5.0.890 — fixed in 3.5.0.880, 3.5.0.890
- Adobe Air Sdk: before 3.5.0.880; before 3.5.0.890 — fixed in 3.5.0.880, 3.5.0.890
- Adobe Flash Player 24.0.0.186 and earlier.: from 10.3 before 10.3.183.48; from 11.5 before 11.5.502.135; from 11.2 before 11.2.202.258; from 11.1 before 11.1.111.29; from 11.1 before 11.1.115.34; from 11.5 before 11.5.502.136 — fixed in 10.3.183.48, 11.1.111.29, 11.1.115.34, 11.2.202.258, 11.5.502.135, 11.5.502.136
How to fix
Upgrade to a fixed version: Adobe Air 3.5.0.880, 3.5.0.890; Adobe Air Sdk 3.5.0.880, 3.5.0.890; Adobe Flash Player 24.0.0.186 and earlier. 10.3.183.48, 11.1.111.29, 11.1.115.34, 11.2.202.258. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2013-02/msg00033.html
- http://www.adobe.com/support/security/bulletins/apsb12-27.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2013-02/msg00033.html
- http://www.adobe.com/support/security/bulletins/apsb12-27.html
Get alerted when CVE-2012-5678 or the next vulnerability affects your stack