What’s Vulnerable › Vulnerabilities

CVE-2012-5840

Description

Use-after-free vulnerability in the nsTextEditorState::PrepareEditor function in Mozilla Firefox before 17.0, Firefox ESR 10.x before 10.0.11, Thunderbird before 17.0, Thunderbird ESR 10.x before 10.0.11, and SeaMonkey before 2.14 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-4214.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 10.0.11, 17.0; Mozilla Seamonkey 2.14; Mozilla Thunderbird 17.0; Mozilla Thunderbird ESR 10.0.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-5840 or the next vulnerability affects your stack