What’s Vulnerable › Vulnerabilities
CVE-2012-5887
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-11-17 · updated 2026-10-09
- Weakness: CWE-287
Description
The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.36, 6.x before 6.0.36, and 7.x before 7.0.30 does not properly check for stale nonce values in conjunction with enforcement of proper credentials, which makes it easier for remote attackers to bypass intended access restrictions by sniffing the network for valid requests.
Affected products
- Apache Tomcat: from 5.5.0 before 5.5.36; from 6.0.0 before 6.0.36; from 7.0.0 before 7.0.30 — fixed in 5.5.36, 6.0.36, 7.0.30
How to fix
Upgrade to a fixed version: Apache Tomcat 5.5.36, 6.0.36, 7.0.30. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2012-12/msg00089.html
- http://lists.opensuse.org/opensuse-updates/2012-12/msg00090.html
- http://lists.opensuse.org/opensuse-updates/2013-01/msg00037.html
- http://rhn.redhat.com/errata/RHSA-2013-0623.html
- http://rhn.redhat.com/errata/RHSA-2013-0629.html
- http://rhn.redhat.com/errata/RHSA-2013-0631.html
- http://rhn.redhat.com/errata/RHSA-2013-0632.html
- http://rhn.redhat.com/errata/RHSA-2013-0633.html
- http://rhn.redhat.com/errata/RHSA-2013-0640.html
- http://rhn.redhat.com/errata/RHSA-2013-0647.html
- http://rhn.redhat.com/errata/RHSA-2013-0648.html
- http://rhn.redhat.com/errata/RHSA-2013-0726.html
Get alerted when CVE-2012-5887 or the next vulnerability affects your stack