What’s Vulnerable › Vulnerabilities
CVE-2012-6071
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-19 · updated 2026-06-16
- Weakness: CWE-295
Description
nuSOAP before 0.7.3-5 does not properly check the hostname of a cert.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Nusoap Project Nusoap: before 0.7.3-5 — fixed in 0.7.3-5
How to fix
Upgrade to a fixed version: Nusoap Project Nusoap 0.7.3-5. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2012/12/27/1
- http://www.openwall.com/lists/oss-security/2013/01/15/6
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696707
- https://security-tracker.debian.org/tracker/CVE-2012-6071
- http://www.openwall.com/lists/oss-security/2012/12/27/1
- http://www.openwall.com/lists/oss-security/2013/01/15/6
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696707
- https://security-tracker.debian.org/tracker/CVE-2012-6071
Get alerted when CVE-2012-6071 or the next vulnerability affects your stack