What’s Vulnerable › Vulnerabilities
CVE-2012-6075
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-02-13 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the e1000_receive function in the e1000 device driver (hw/e1000.c) in QEMU 1.3.0-rc2 and other versions, when the SBP and LPE flags are disabled, allows remote attackers to cause a denial of service (guest OS crash) and possibly execute arbitrary guest code via a large packet.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- Debian Linux: 6.0
- Fedoraproject Fedora: 16, 17, 18
- Opensuse: 12.1, 12.2
- QEMU: before 1.3.0 — fixed in 1.3.0
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 5.9, 6.4
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Server Aus: 5.9, 6.4
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- RedHat Virtualization: 3.0
- SUSE Linux Enterprise Server: 11-sp1
How to fix
Upgrade to a fixed version: QEMU 1.3.0. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu.git%3Ba=commitdiff%3Bh=b0d9ffcd0251161c7c92f94804dcf599dfa3edeb
- http://lists.fedoraproject.org/pipermail/package-announce/2013-January/097541.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-January/097575.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-January/097705.html
- http://lists.nongnu.org/archive/html/qemu-devel/2012-12/msg00533.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00021.html
- http://lists.opensuse.org/opensuse-updates/2013-04/msg00051.html
- http://lists.opensuse.org/opensuse-updates/2013-04/msg00052.html
- http://rhn.redhat.com/errata/RHSA-2013-0599.html
- http://rhn.redhat.com/errata/RHSA-2013-0608.html
- http://rhn.redhat.com/errata/RHSA-2013-0609.html
- http://rhn.redhat.com/errata/RHSA-2013-0610.html
Get alerted when CVE-2012-6075 or the next vulnerability affects your stack