What’s Vulnerable › Vulnerabilities
CVE-2012-6094
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-20 · updated 2026-06-16
- Weakness: CWE-863
Description
cups (Common Unix Printing System) 'Listen localhost:631' option not honored correctly which could provide unauthorized access to the system
Affected products
- cups: before 1.5.4-1.1 — fixed in 1.5.4-1.1
- Debian Linux: 8.0, 9.0, 10.0
How to fix
Upgrade to a fixed version: cups 1.5.4-1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/01/04/5
- http://www.securityfocus.com/bid/57158
- https://access.redhat.com/security/cve/cve-2012-6094
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-6094
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2012-6094
- https://exchange.xforce.ibmcloud.com/vulnerabilities/82451
- https://security-tracker.debian.org/tracker/CVE-2012-6094
- http://www.openwall.com/lists/oss-security/2013/01/04/5
- http://www.securityfocus.com/bid/57158
- https://access.redhat.com/security/cve/cve-2012-6094
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-6094
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2012-6094
Get alerted when CVE-2012-6094 or the next vulnerability affects your stack