What’s Vulnerable › Vulnerabilities
CVE-2012-6150
- Severity: low (CVSS 3.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-12-03 · updated 2026-06-16
- Weakness: CWE-20
Description
The winbind_name_list_to_sid_string_list function in nsswitch/pam_winbind.c in Samba through 4.1.2 handles invalid require_membership_of group names by accepting authentication by any user, which allows remote authenticated users to bypass intended access restrictions in opportunistic circumstances by leveraging an administrator's pam_winbind configuration-file mistake.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.04, 13.10
- Samba: from 3.3.10 before 3.4.0; from 3.4.3 before 3.6.22; from 4.0.0 before 4.0.13; from 4.1.0 before 4.1.3 — fixed in 3.4.0, 3.6.22, 4.0.13, 4.1.3
How to fix
Upgrade to a fixed version: Samba 3.4.0, 3.6.22, 4.0.13, 4.1.3. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136864.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-June/134717.html
- http://lists.opensuse.org/opensuse-security-announce/2014-01/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00048.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00088.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00063.html
- http://marc.info/?l=bugtraq&m=141660010015249&w=2
- http://openwall.com/lists/oss-security/2013/12/03/5
- http://rhn.redhat.com/errata/RHSA-2014-0330.html
- http://security.gentoo.org/glsa/glsa-201502-15.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:299
Get alerted when CVE-2012-6150 or the next vulnerability affects your stack