What’s Vulnerable › Vulnerabilities
CVE-2012-6346
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in FortiWeb before 4.4.4 allow remote attackers to inject arbitrary web script or HTML via the (1) redir or (2) mkey parameter to waf/pcre_expression/validate.
Affected products
- Fortinet FortiWeb: before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 4.4.4. Check the vendor advisory for mitigations.
References
- https://fortiguard.com/psirt/FG-IR-012-008
- https://www.vulnerability-lab.com/get_content.php?id=702
- https://fortiguard.com/psirt/FG-IR-012-008
- https://www.vulnerability-lab.com/get_content.php?id=702
Get alerted when CVE-2012-6346 or the next vulnerability affects your stack