What’s Vulnerable › Vulnerabilities
CVE-2012-6639
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-25 · updated 2026-06-16
- Weakness: CWE-269
Description
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
Affected products
- Canonical Ltd. cloud-init: before 0.7.0 — fixed in 0.7.0
- Debian Linux: 8.0, 9.0, 10.0
- SUSE Linux Enterprise Server: 11-sp2, 11-sp3
How to fix
Upgrade to a fixed version: Canonical Ltd. cloud-init 0.7.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/03/06/7
- https://access.redhat.com/security/cve/cve-2012-6639
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-6639
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2012-6639
- https://security-tracker.debian.org/tracker/CVE-2012-6639
- https://www.securityfocus.com/bid/66019/references
- http://www.openwall.com/lists/oss-security/2014/03/06/7
- https://access.redhat.com/security/cve/cve-2012-6639
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-6639
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2012-6639
- https://security-tracker.debian.org/tracker/CVE-2012-6639
- https://www.securityfocus.com/bid/66019/references
Get alerted when CVE-2012-6639 or the next vulnerability affects your stack