What’s Vulnerable › Vulnerabilities
CVE-2012-6671
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-11 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in actions/main.php in the DragonByte Technologies Forumon RPG module before 1.0.8 for vBulletin when creating a new monster, allow remote attackers to inject arbitrary web script or HTML via the (1) monster[title] or (2) monster[description] parameters.
Affected products
- Dragonbyte-Tech Forumon Rpg Module: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Dragonbyte-Tech Forumon Rpg Module 1.0.8. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/48490
- http://secunia.com/advisories/48514
- http://www.dragonbyte-tech.com/f4/vbactivity-vbshout-forumon-rpg-vbdownloads-vbquiz-updates-security-releases-6876/
- http://www.securityfocus.com/bid/52707
- http://secunia.com/advisories/48490
- http://secunia.com/advisories/48514
- http://www.dragonbyte-tech.com/f4/vbactivity-vbshout-forumon-rpg-vbdownloads-vbquiz-updates-security-releases-6876/
- http://www.securityfocus.com/bid/52707
Get alerted when CVE-2012-6671 or the next vulnerability affects your stack