What’s Vulnerable › Vulnerabilities

CVE-2012-6689

Description

The netlink_sendmsg function in net/netlink/af_netlink.c in the Linux kernel before 3.5.5 does not validate the dst_pid field, which allows local users to have an unspecified impact by spoofing Netlink messages.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.0.44, 3.2.30, 3.4.12, 3.5.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-6689 or the next vulnerability affects your stack