What’s Vulnerable › Vulnerabilities
CVE-2012-6702
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-16 · updated 2026-06-16
- Weakness: CWE-310
Description
Expat, when used in a parser that has not called XML_SetHashSalt or passed it a seed of 0, makes it easier for context-dependent attackers to defeat cryptographic protection mechanisms via vectors involving use of the srand function.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- Android: 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1
- libexpat project libexpat: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2016/dsa-3597
- http://www.openwall.com/lists/oss-security/2016/06/03/8
- http://www.openwall.com/lists/oss-security/2016/06/04/1
- http://www.securityfocus.com/bid/91483
- http://www.ubuntu.com/usn/USN-3010-1
- https://security.gentoo.org/glsa/201701-21
- https://source.android.com/security/bulletin/2016-11-01.html
- https://www.tenable.com/security/tns-2016-20
- http://www.debian.org/security/2016/dsa-3597
- http://www.openwall.com/lists/oss-security/2016/06/03/8
- http://www.openwall.com/lists/oss-security/2016/06/04/1
- http://www.securityfocus.com/bid/91483
Get alerted when CVE-2012-6702 or the next vulnerability affects your stack