What’s Vulnerable › Vulnerabilities
CVE-2012-6712
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-27 · updated 2026-06-16
- Weakness: CWE-119
Description
In the Linux kernel before 3.4, a buffer overflow occurs in drivers/net/wireless/iwlwifi/iwl-agn-sta.c, which will cause at least memory corruption.
Affected products
- Linux kernel: from 2.6.27 before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: Linux kernel 3.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2da424b0773cea3db47e1e81db71eeebde8269d4
- https://github.com/torvalds/linux/commit/2da424b0773cea3db47e1e81db71eeebde8269d4
- https://mirrors.edge.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.4
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2da424b0773cea3db47e1e81db71eeebde8269d4
- https://github.com/torvalds/linux/commit/2da424b0773cea3db47e1e81db71eeebde8269d4
- https://mirrors.edge.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.4
Get alerted when CVE-2012-6712 or the next vulnerability affects your stack