What’s Vulnerable › Vulnerabilities
CVE-2013-0156
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 99.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-01-13 · updated 2026-06-16
- Weakness: CWE-20
Description
active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion.
Affected products
- Debian Linux: 6.0, 7.0
- Ruby on Rails: from 3.2.0 before 3.2.11 — fixed in 3.2.11
- rubyonrails Ruby On Rails: before 2.3.15; from 3.0.0 before 3.0.19; from 3.1.0 before 3.1.10 — fixed in 2.3.15, 3.0.19, 3.1.10
How to fix
Upgrade to a fixed version: Ruby on Rails 3.2.11; rubyonrails Ruby On Rails 2.3.15, 3.0.19, 3.1.10. Check the vendor advisory for mitigations.
References
- http://ics-cert.us-cert.gov/advisories/ICSA-13-036-01A
- http://lists.apple.com/archives/security-announce/2013/Mar/msg00002.html
- http://rhn.redhat.com/errata/RHSA-2013-0153.html
- http://rhn.redhat.com/errata/RHSA-2013-0154.html
- http://rhn.redhat.com/errata/RHSA-2013-0155.html
- http://weblog.rubyonrails.org/2013/1/28/Rails-3-0-20-and-2-3-16-have-been-released/
- http://www.debian.org/security/2013/dsa-2604
- http://www.fujitsu.com/global/support/software/security/products-f/sw-sv-rcve-ror201301e.html
- http://www.insinuator.net/2013/01/rails-yaml/
- http://www.kb.cert.org/vuls/id/380039
- http://www.kb.cert.org/vuls/id/628463
- https://community.rapid7.com/community/metasploit/blog/2013/01/09/serialization-mischief-in-ruby-land-cve-2013-0156
Get alerted when CVE-2013-0156 or the next vulnerability affects your stack