What’s Vulnerable › Vulnerabilities

CVE-2013-0170

Description

Use-after-free vulnerability in the virNetMessageFree function in rpc/virnetserverclient.c in libvirt 1.0.x before 1.0.2, 0.10.2 before 0.10.2.3, 0.9.11 before 0.9.11.9, and 0.9.6 before 0.9.6.4 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code by triggering certain errors during an RPC connection, which causes a message to be freed without being removed from the message queue.

Affected products

How to fix

Upgrade to a fixed version: libvirt 0.10.2.3, 0.9.11.9, 0.9.6.4, 1.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2013-0170 or the next vulnerability affects your stack