What’s Vulnerable › Vulnerabilities
CVE-2013-0334
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-10-31 · updated 2026-06-16
- Weakness: CWE-20
Description
Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.
Affected products
- rubygem-bundler: before 1.7.0 — fixed in 1.7.0
- Fedoraproject Fedora: 19, 20, 21
- Opensuse: 13.1, 13.2
How to fix
Upgrade to a fixed version: rubygem-bundler 1.7.0. Check the vendor advisory for mitigations.
References
- http://bundler.io/blog/2014/08/14/bundler-may-install-gems-from-a-different-source-than-expected-cve-2013-0334.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140609.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140654.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140655.html
- http://lists.opensuse.org/opensuse-updates/2015-03/msg00092.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securityfocus.com/bid/70099
- https://security.gentoo.org/glsa/201609-02
- http://bundler.io/blog/2014/08/14/bundler-may-install-gems-from-a-different-source-than-expected-cve-2013-0334.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140609.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140654.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/140655.html
Get alerted when CVE-2013-0334 or the next vulnerability affects your stack