What’s Vulnerable › Vulnerabilities
CVE-2013-0756
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-01-13 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in the obj_toSource function in Mozilla Firefox before 18.0, Firefox ESR 17.x before 17.0.2, Thunderbird before 17.0.2, Thunderbird ESR 17.x before 17.0.2, and SeaMonkey before 2.15 allows remote attackers to execute arbitrary code via a crafted web page referencing JavaScript Proxy objects that are not properly handled during garbage collection.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- Mozilla Firefox: before 17.0.2; before 18.0 — fixed in 17.0.2, 18.0
- Mozilla Seamonkey: before 2.15 — fixed in 2.15
- Mozilla Thunderbird: before 17.0.2 — fixed in 17.0.2
- Mozilla Thunderbird ESR: before 17.0.2 — fixed in 17.0.2
- Opensuse: 11.4, 12.1, 12.2
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp2
- SUSE Linux Enterprise Server: 10-sp4, 11-sp2
- SUSE Linux Enterprise Software Development Kit: 10-sp4, 11-sp2
How to fix
Upgrade to a fixed version: Mozilla Firefox 17.0.2, 18.0; Mozilla Seamonkey 2.15; Mozilla Thunderbird 17.0.2; Mozilla Thunderbird ESR 17.0.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00017.html
- http://www.mozilla.org/security/announce/2013/mfsa2013-19.html
- http://www.ubuntu.com/usn/USN-1681-1
- http://www.ubuntu.com/usn/USN-1681-2
- http://www.ubuntu.com/usn/USN-1681-4
- https://bugzilla.mozilla.org/show_bug.cgi?id=814029
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A17101
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00007.html
Get alerted when CVE-2013-0756 or the next vulnerability affects your stack