What’s Vulnerable › Vulnerabilities
CVE-2013-0760
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-01-13 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the CharDistributionAnalysis::HandleOneChar function in Mozilla Firefox before 18.0, Thunderbird before 17.0.2, and SeaMonkey before 2.15 allows remote attackers to execute arbitrary code via a crafted document.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- Mozilla Firefox: before 10.0.11; before 18.0; from 17.0 before 17.0.2 — fixed in 10.0.11, 17.0.2, 18.0
- Mozilla Seamonkey: before 2.15 — fixed in 2.15
- Mozilla Thunderbird: before 17.0.2 — fixed in 17.0.2
- Mozilla Thunderbird ESR: before 10.0.12; from 17.0 before 17.0.2 — fixed in 10.0.12, 17.0.2
- Opensuse: 11.4, 12.1, 12.2
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp2
- SUSE Linux Enterprise Server: 10-sp4, 11-sp2
- SUSE Linux Enterprise Software Development Kit: 10-sp4, 11-sp2
How to fix
Upgrade to a fixed version: Mozilla Firefox 10.0.11, 17.0.2, 18.0; Mozilla Seamonkey 2.15; Mozilla Thunderbird 17.0.2; Mozilla Thunderbird ESR 10.0.12, 17.0.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00017.html
- http://www.mozilla.org/security/announce/2013/mfsa2013-02.html
- http://www.ubuntu.com/usn/USN-1681-1
- http://www.ubuntu.com/usn/USN-1681-2
- http://www.ubuntu.com/usn/USN-1681-4
- https://bugzilla.mozilla.org/show_bug.cgi?id=780979
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A17086
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00007.html
Get alerted when CVE-2013-0760 or the next vulnerability affects your stack