What’s Vulnerable › Vulnerabilities
CVE-2013-0871
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-02-18 · updated 2026-06-16
- Weakness: CWE-362
Description
Race condition in the ptrace functionality in the Linux kernel before 3.7.5 allows local users to gain privileges via a PTRACE_SETREGS ptrace system call in a crafted application, as demonstrated by ptrace_death.
Affected products
- Linux kernel: from 3.5 before 3.7.5 — fixed in 3.7.5
How to fix
Upgrade to a fixed version: Linux kernel 3.7.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=9899d11f654474d2d54ea52ceaa2a1f4db3abd68
- http://lists.opensuse.org/opensuse-security-announce/2013-02/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00005.html
- http://rhn.redhat.com/errata/RHSA-2013-0567.html
- http://rhn.redhat.com/errata/RHSA-2013-0661.html
- http://rhn.redhat.com/errata/RHSA-2013-0662.html
- http://rhn.redhat.com/errata/RHSA-2013-0695.html
- http://www.debian.org/security/2013/dsa-2632
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.7.5
- http://www.openwall.com/lists/oss-security/2013/02/15/16
- http://www.ubuntu.com/usn/USN-1736-1
Get alerted when CVE-2013-0871 or the next vulnerability affects your stack